NodeMaven

Proxy instability for North American customers
Resolved·Degraded performance

Proxy is now stable

Tue, Jun 3, 2025, 12:44 PM
(1 month ago)
·
Affected components
Updates

Resolved

Proxy is now stable

Tue, Jun 3, 2025, 12:44 PM

Investigating

For some of the customers located in North American region, the proxy shows degraded performance. Our engineers already working on a solution to the problem. Subscribe to notifications on this page or contact support to get the resolution update

Tue, Jun 3, 2025, 12:41 PM
Powered by

Never gonna let you down