Never gonna let you down
Resolved
Proxy is now stable across all regions
Investigating
For some of the customers located in North American region, the proxy shows degraded performance. Our engineers already working on a solution to the problem. Subscribe to notifications on this page or contact support to get the resolution update